Dropping Legacy App Support

Please Update Your App!

As of August 1st we will be dropping support for older versions of the Plickers app (versions prior to 2015). To ensure you don't experience any interruption of service or issues, please make sure have upgraded your app to the latest version on the App store (iPhone/iPad) or Google Play Store (Android).

Does this affect me?

This should only affect versions of the app downloaded prior to 2015 so as long as you are using version 3+ for iOS or version 2+ for Android, you should not be affected. To be safe, update the Plickers app!

Why now? 

We are frequently adding new improvements to the app whether it's features or security updates, so we always recommend using the latest version. We've reached a point where these older versions of the app are missing core Plickers functionality and want to make sure you have the best experience available.

I'm Still Not Sure...

If you have any questions or concerns to whether you're on a safe version, don't hesitate to contact us directly. 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk